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INTRO 

Types of Objects Database – A database is a large sets of data stored as individual records in one or 
more tables. 

Tables – A table is a list of information where the data is stored. A table consists of a 
number of records entered into columns/fields. The type of data you enter into 
columns/fields is based on the type of fields you define, such as a text field, a number 
field, a date field, and so forth. Access can create one or more tables of information 
per file, and even create relationships between the tables. Once you have data in the 
table, you can filter the data to see just some of the records, or sort the data, find 
data in the table, and so forth. An example of a table is a list of records of Salesperson, 
Date, and Sales amount, and Comment 

Queries – Queries are based on tables. They enable you to see only some of the 
information of a table, or even just some of the fields. Queries do not store any data, 
as the table stores it. Queries are thus a way to delimit what data you see from a 
table.  An example of a query is a list of records of Salesperson, Date, and Sales 
amount, but without the Comment information, and only records between April 1 
2016 and May 1 2016. 

Forms – Forms are convenient ways to enter data into tables. Forms give the user an 
easy and flexible way to enter data. Like queries, the data is not stored in the form, 
but in the underlying table (r query) that the form is based on. Whereas tables and 
queries are normally just lists of records, a form shows the data one record at a time, 
with plenty of room to enter longer bits of information. An example of a form is an 
easy way to enter the sales information one record per screen, with plenty of room 
to enter Comments information. 

Reports – Reports are powerful ways to present data. A report is based on a table or 
query (or even related tables). The data cannot be typed into in a report, only viewed.  
An example of a report is to have the sales data grouped by salesperson, and within 
each salesperson’s area are the detail sales records per each person. 

GETTING STARTED 

Create a Database File To create an Access database/file, open Access, and click Blank database. Then click 
little folder on right to navigate to desired location to store the file. (e.g. Desktop). 
Then type in a name for the database (eg Sales Database, and then click Create. 

Backups of Database 
File 

It’s a good idea to regularly do backups of your Access file, and do so under another 
name. Eg if your file is named Sales, you can do a backup as Sales 51916 720am. If 
you later mess it up Sales, you can always go back to the most recent backup.  

To backup the database/file select File, Save As, navigate to a desired location, type 
in a backup name (e.g. BU Sales database), and click OK.  

TABLES 

Create and Name a 
New Table 

When you build a new database file, a default temporary table is created, with one 
field defined. You can then choose to continue building the table in the current 
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Datasheet view using this approach, or you can define your table from scratch 
(recommended method). 

To define a table from scratch, close the existing temp table, by right clicking the tab 
that appears, and selecting Close. Do not save if prompted. Then select Create, Table, 
Table Design. Now you can define your fields. At any point, you can click the Save 
button on the Quick Access Toolbar to save the table with a name of your choosing 
(eg tblCustomers).  

To define a table after you create a new, blank database, you will see one column 
defined, called ID. Switch to Design View, and add additional fields as necessary. 

At any point, you can click the Save button on the Quick Access Toolbar to save the 
table with a name of your choosing (eg tblCustomers). 

Define Fields for Table Before you enter data into the database, you need to define the fields. To do that 
using the from scratch method (see above), right click the table (eg tblCustomers) on 
the left side of the screen and then then select Design view. (If there is no table 
defined, then first select Home, Table, Table Design, and Save the table; see above). 

One by one enter the fields you want to include in the table, and with each one select 
the field type to the right of it. Eg the first field can be CustomerID with an 
AutoNumber type field. The proceed to entering other fields with their designated 
field types. Eg CustomerName using the Short Text field type. (Field types are 
explained next.) 

When you are done entering field name with their field types, click the Save button 
on the Quick Access toolbar. Note: If you created an AutoNumber field, you will be 
prompted to create a Primary Key on that field Accept doing so. 

Field Types Here is a brief explanation of the main field type: 

Short Text – Enables the user to enter up to 256 characters of data into this field per 
record. 

Long Text – Enables the user to enter long passages of text per record in this field, 
such as Comments or Sales history. 

Number – Enables the user to enter numeric information like 1000. 

Date/Time – Enables the user to enter a date into this field. 

Currency – When enter dollars and cents with dollar signs and decimals. (e.g. 
$2500.00) 

Autonumber – This simply numbers the records of data. The default ID field is 
automatically assigned an Autonumber field type. Also, you will not normally be able 
to change the data of an Autonumber field. 

Yes/No – Will by default show a check box, which can be checked or not by the user. 

Hyperlink – Enables the user to enter a web address. 

Calculated – Enables you to enter an expression such as adding two fields together. 
You enter the expression by clicking on the three dots in the Expression field property 
at the bottom of  the page, which opens the Expression Builder where you can enter 
the formula  (eg  [Sales] + [Profits] 
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Lookup Wizard – Starts a wizard that enables the user to select from a few 
predefined entries that will appear in a pop-up list, just as Positive, Neutral, or 
Negative. Or the wizard can look up entries from another table (such as a list of States 
or Contacts, etc.). The user would select one of the items in the pop-up that appears 
for this field for each record created. 

Field Type Properties  

 

For each field type there are properties shown below in the Properties area.  

-Eg for a Short Text field you can change its default Field Size from 255 to 2 which 
will limit the user to only that number of charters when entering data into that field 
in a record.  

-Or for many types of fields, you can set the Index property to Yes (No Duplicates) 
meaning the table will be sped up and also not allow for any duplicate entries 

-Or a Long Text field you can change the Text format property to Rich Text, enabling 
the user to format pieces of text with bold, italic, etc. formatting when entering data  

Or Currency field, change the decimals setting from 2 to 0.  

Or for many types of field, including Yes/No field you can have a Default Value of Yes 
(meaning the check box is automatically checked for each record of data created.) 
etc. etc.  

Or for several types of field, including a Short Text field, you can create an Input Mask 
using its wizard so the content is formatted like a phone number or a zip code. 

Save Changes to Table When you are done entering the field name and their associated field type, click the 
Save button. To close the table, right click the tab above it and select Close. To reopen 
the table in Design view, right click it from the left side of the screen and select Design 
View.  

Entering Data into  
Table 

To enter data into the table, double click on it from among the tables on the left.  You 
will be in Datasheet view.  

Click to the right of where it says New, and start entering data by typing it in or 
selecting from pop-up, etc. and then hit Tab or enter to move to next field. Continue 
entering this way. Shift Tab goes backwards. After you tab past the end of the record, 
it is automatically saved. 

To change a record, go to it, make the change and then select one of the arrows at 
the bottom of the screen to go to another record, or select Refresh All in the Records 
area of the Home tab.  

To delete a record, click on the rectangle to the left of the record so it is highlighted 
with dark background, and then click on the Delete arrow (not Delete itself) in the 
Records area of the Home tab, and select Delete Record from the pop-up.  

Sorting, Filtering, 
Searching Data in 
Table 

Sorting – To sort the table, click the down arrow on a field heading and select (eg) 
From A to Z (or From Smallest to Highest). Alternately, click in the desired field to sort 
by and then click Home/Sort & Filtering/Ascending (alphabetical or lowest to highest 
value) in the or Sort Descending (reverse alphabetical or highest to lowest value). 
When you are done sorting, click Home/Sort and Filtering/Remove Sort.  

Basic Filtering – To filter the table (i.e. delimit the number of records showing by a 
criteria), click the down arrow on a field heading and deselect and then select the 
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entries you want from the choices in lower part of screen. Alternately, click in the 
desired field to filter by and then click Home/Sort & Filtering/ and click the Filter (big 
funnel) icon. Then from the dialogue box, unselect and select the criteria you want, 
and click OK. Only the records that meet the criteria are visible. To unfilter, click the 
down arrow on a field heading and choose Select All box. Alternately, click the Toggle 
Filter button in Home/Sort & Filtering area. 

Advanced Filtering -- Click in the table, on the Home tab in the Sort and Filtering area, 
select Advanced and then Filter by Form in the Sort and Filter area. Select the criteria 
from one or more of the pop-ups that appear next to the field headings (or type in 
criteria), and then select Toggle Filter from the Sort and Filter area. Click Toggle Filter 
again to unfilter. 

Custom Filters: From the pop-up that appears by clicking the field heading, select 
one of the predesignated filters that appear for Numbers, Date, and other type fields. 
Eg, for Numbers you can select Greater than or equals to and enter the amount; for 
a date field you could select this week or this month or next month, etc.  To unfilter, 
either click the filed heading down arrow and select Clear Filter … or click the Toggle 
Filter button in Home/Sort & Filtering area. 

Searching -- Method 1: To search for content among the records, click in the Search 
box in the bottom of the screen and type in what you are looking for. E.g. type “Long” 
and you will go to the first instance. If you then hit enter you will go to the next 
instance. You can click the arrows to go to the next instance. Note that W* would 
find all records that start with a W in that field. Be sure to remove the search criteria 
at the bottom of the page when you are done. Method 2: On the Home tab select 
Find in the Find area, type in the desired value, and click Next. Note to select from 
Match choices of Whole Field or Any Part of Field. You can also follow this basic 
procedure with Find and Replace (which replaces the found text with the desired 
replacement text). 

RELATIONSHIPS 

Establishing 
Relationships Between 
Tables 

A relationship helps you combine data from two different tables. In an Access 
desktop database, you can create a relationship in the Relationships window. 

Eg let’s say we have two tables. We want to track both our employees and our 
customer or in our database. One of employees and the other containing the orders 
taken by these employees. Each employee would then appear once in the Employees 
database, while the same employee could appear many times in the Order database. 
Yet we could create a relationship between them. Why? Well rather than entering 
the phone number onto each record of the Orders database, we could look it up from 
the Employees database by setting up a relationship between the two tables and 
then using fields from one another in a query.  

 

Create a relationship in an Access desktop database 

-On the Database Tools tab, in the Relationships group, click Relationships. 



 8 

-If you haven't yet defined any relationships, the Show Table dialog box automatically 
appears. If it doesn't appear, on the Design tab, in the Relationships group, click Show 
Table. 

The Show Table dialog box displays all of the tables and queries in the database. To 
see only tables, click Tables. 

-Select one or more tables, and then click Add. After you have finished adding tables, 
click Close. 

-Drag a field (typically the primary key) from one table to the common field (the 
foreign key) in the other table. To drag multiple fields, press the Ctrl key, click each 
field, and then drag them. 

-The Edit Relationships dialog box appears. 

Verify that the field names shown are the common fields for the relationship. If a 
field name is incorrect, click on the field name and select the appropriate field from 
the list. 

-To enforce referential integrity for this relationship, select the Enforce Referential 
Integrity box.  This insures that you will only be able to enter data into a field in the 
many table if it also already exists in a corresponding field in the one table. Eg when 
you enter suppliers in the many table, you cannot enter a supplier unless it already 
exists in the 1 table. (“Many” table means that for the Supplier there can be many 
instances entered of the same supplier; whereas the “One” table can only have one 
instance.)  

-Click Create. 

-When you are finished in the Relationships window, click Save to save your 
relationship layout changes. 

Access draws a relationship line between the two tables. If you selected the Enforce 
Referential Integrity check box, the line appears thicker at each end. In addition, 
again only if you selected the Enforce Referential Integrity check box, the number 1 
appears over the thick portion on one side of the relationship line, and the infinity 
symbol (∞) appears over the thick portion on the on the other side of the line. This 
indicates a One to Many relationship between the two tables based on the common 
joined field. 

Cascade Update, Delete  

-When joining tables in a One to Many relationship use 'Cascade Update Related 
Records' if you want all related records in the Many table to change (in the Joined 
field), when the corresponding record in the One table changes. 

-When joining tables in a One to Many relationship use 'Cascade Delete Related 
Records' if you want all related records in the Many table to be deleted when the 
corresponding record (based on the joined field) in the One table is deleted.  

Relationship Report 

With the Relationships window open, click the Relationships Report in the Tools area. 
That creates a report of the relationships. (ep) 
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Note on Queries Using 
Multi-Related Tables 

If you created a relationship between tables, then if you use any combination of 
those tables in a query, they will automatically be linked based on the relation 
specified. Eg if Customers and Sales have a 1 to many relationship with referential 
integrity on, as defined in the Relationships window, then they will automatically be 
related this way when they are included in a (multi-table) query. 

QUERIES 

Types of Query Simple (Select) Query (has no Criteria) – Simply shows all of the fields from one or 
more tables with all fields or just some of the fields selected.  

Simple (Select) Query with Criteria – Shows all of the fields from one or more tables 
with all fields or just some of the fields selected., but records are restricted to the 
criteria set in one or more fields. Eg State is limited to California entries only. 

Totals Queries – Shows query data as subtotals  

Crosstab Queries – Show query data down and across 

Parameter Query – User is prompted to enter the values for a criteria each time the 
query is run. (instead of the criteria hard wired, eg State field = California in the 
query). 

Action Queries – Action queries are advanced queries. An Action Query does 
something to the data set of records showing in a query, such Update the records in 
a sales field by a certain amount, or Append records from one data set to another, or 
Delete records based on certain criteria, as Make a new Table out of some data set, 
etc.   

Simple (Select) Query 

 

Simple (Select) Query (has no Criteria) and simply shows all or some of the fields from 
the underlying table.  

To create a basic (Select) query, click Create > Query Design. In the Show Table box, 
double-click the Products table > Close. Now drag one or more fields into the Grid 
area below. Now click the View button on the Home tab to run it.  (If you want you 
can later on add criteria to the Select Query (explained below.) 

To create a query with the wizard, select click Create > Query Wizard, and follow the 
steps. 

Select Query with 
Criteria 

You can also limit the number of records that show in a query by setting a 
predesignated, fixed criteria for the query. Eg to show just those records where State 
is California. 

To create a Select query with Criteria, click Create > Query Design. In the Show Table 
box, double-click the Products table > Close. In the criteria row, under eg List Price, 
add a criteria. For example, >=10 to show a list of products where the List Price is 
greater than or equal to $10.00. Now click the View button on the Home tab to run 
it. (You can also add criteria to a simple Select query by opening it in Design view and 
adding criteria.)  

AND, OR Criteria -- You can also enter more than one criteria by entering the desired 
info into the criteria row for several items. E.g. under State you could have CA, and 
under List Price you can have >=10. This will find records that match BOTH criteria 
together; only select records where State is CA and List Price is >=10. If you want to 
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match it to EITHER criteria, where State is Ca or the List Price is >=10, then you put 
one of the two criteria in the area just below the Criteria (in the Or area) for that 
field.  

Example Criteria for 
Queries 

Number Criteria 

Exactly match a value, such as 100 – 100 

-Do not match a value, such as 1000 -- Not 1000 

-Contain a value smaller than a value, such as 100 -- < 100 -- <= 100 

-Contain a value larger than a value, such as 99.99 -- >99.99 -- >=99.99 

-Contain one of the two values, such as 20 or 25 -- -- 20 or 25 

-Contain a value that falls with a range of values – Example 1: >49.99 and <99.99    
Example 2: Between 50 and 100 

-Starts with anything and ends with specified digits -- *4.99  

-Starts with specific digits and the rest is anything -- 4.99*  

-Contain null (or missing) values -- Is Null    

-Contain non-null values -- Is Not Null 

More examples: 

https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-
8684-4552-ac03-aba746fb29d8 

 

Date Criteria 

Exactly match a date - #2/2/2012# 

Does not match a date - Not #2/2/2012# 

Before a specific date - <#2/2/2012#; after a specific date - >#2/2/2012# 

Values that fall within a range - >#2/2/2006# and <#2/4/2006# 

Filter for null (or missing) values - Is Null 

Filter for non-null values - Is Not Null 

Contains todays date  Date() 

Contain yesterday's date - Date()-1 

More examples: 

https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-
8684-4552-ac03-aba746fb29d8 

 

Text Criteria 

-Exactly match a value, such as China -- China 

-Do not match a value, such as Mexico -- Not Mexico 

-Contains the specified string inside the text, such as contains Korea -- *Korea* 

-Begin with the specified string, but thereafter is anything, such as starts with U -- 
U* 

-Start with anything, but ends with a specified string (such as "ina") -- *ina 

-Contain null (or missing) values -- Is Null 

https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-8684-4552-ac03-aba746fb29d8
https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-8684-4552-ac03-aba746fb29d8
https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-8684-4552-ac03-aba746fb29d8
https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-8684-4552-ac03-aba746fb29d8
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-Do not contain null (missing) values -- Is Not Null 

More examples: 

https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-
8684-4552-ac03-aba746fb29d8 

Select Query Based on 
Multiple Tables 

 

You can create a query that utilizes fields from two or more tables. 

To do that, click Query Design. In the Show Table dialog box, on the Tables tab, add 
the tables. Close the Show Table dialog box. Note the line (called a join) that connects 
the fields. This line shows the relationship between the two tables. Now double click 
or drag the fields you want to add them into the query design grid. If you want, you 
can also set criteria for one or more fields in the grid.  

To see the results, in the Results group, in the Design tab, click Run to see the 
resulting records.  

Multi-Table Joins in a 
Query 

Relationships Based Join 

If you add two or more tables to the query, you need to join them on a common field. 
If you already defined the relationship in the Relationships windows, a (One to Many) 
link line will show. Otherwise, you need to click on the field in the first table, and then 
drag to the corresponding field in the second table. (eg ID field of Suppliers (one) 
table, to Supplier field in the Transactions (many) table.) By default and Inner join 
(#1) is created. I.e. you will see a straight line between the two.  

The Join types are described next. Note that to link the two fields, they have to be of 
the same data type; eg Number with Number (or Autonumber) field, Text with Text 
field, etc. 

#1 (Inner Join) 
When you first run the query, it brings up all the records where there are matching 
records for the common field (eg Customer Name) between the One and Many Table. 
This is an Inner Join. 

#2 (Left Outer Join) 
Once you create the Inner Join above, double click on the link line, and select #2. It 
will bring up all the records from the “1” table (eg Customers), plus those records 
from the “Many” table that have matching records in the common linking field (eg 
CustomerName) in the One table. 

#3 (Right Outer Join) 
Once you create the Inner Join above, double click on the link line, and select #3. It 
will bring up all the records from the “Many” table (eg Orders), plus those records 
from the “Many” table that have matching records in the common linking field (eg 
CustomerName) in the One table. 

Intermediary 
(Junction) Table 

If in a multi-table query there are no common fields between the tables, try adding 
another table to the query that has a joining field(s) to the other two tables, relinking 
as necessary. 

Sorting, Filtering, 
Searching Data in 
Query  

Open a query from the left side of the screen. Then: 

Sorting – To sort the query, click in the desired field to sort by and then click 
Home/Sort and Filtering/Ascending (alphabetical or lowest to highest value) in the or 

https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-8684-4552-ac03-aba746fb29d8
https://support.office.com/en-us/article/examples-of-query-criteria-3197228c-8684-4552-ac03-aba746fb29d8
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Sort Descending (reverse alphabetical or highest to lowest value). When you are done 
sorting, click Remove Sort. 

Secondary Sort – If you have a sort, and then want to define a secondary sort, do 
another sort on another field (as explained above). Now the second sort will become 
the primary sort, and the first sort will become the secondary (subsort) sort. 

Filtering – Method 1: To filter the query (i.e. delimit the number of records showing 
by a criteria), click in the desired field to filter by and then click Home/Sort and 
Filtering/ and click the Filter (big funnel) icon. Then from the dialogue box, unselect 
and select the criteria you want, and click OK. Only the records that meet the criteria 
are visible. To unfilter, click the highlighted Filtered button at the bottom of the page.  

Predefined Filters: From the pop-up that appears by clicking the Filter button, you 
can also select one of the predesignated filters that appear for Numbers, Date, and 
other type fields. Eg, for Numbers you can select greater than or equals to and enter 
the amount; for a date field you could select this week or this month or next month, 
etc.  

Method 2 (Advanced): To filter the query, click in the query, on the Home tab, select 
Advanced and then Filter by Form in the Sort and Filter area. Select the criteria from 
one or more of the pop-ups that appear next to the field headings (or type in criteria), 
and then select Toggle Filter from the Sort and Filter area. Click Toggle Filter again to 
unfilter. 

Searching -- Method 1: To search for content among the records, click in the Search 
box in the bottom of the screen and type in what you are looking for. E.g. type “Long” 
and you will go to the first instance. If you then hit enter you will go to the next 
instance. Be sure to remove the search criteria at the bottom of the page when you 
are done. Method 2: On the Home tab select Find in the Find area, type in the desired 
value, and click Next. Note to select from Match choices of Whole Field or Any Part 
of Field. You can also follow this basic procedure with Find and Replace. 

Calculation 
Expressions in Query 

 

You can also create calculations in a query, that say multiplies one field by another 
and places it in its own field. Eg Sales Amount X Commission rate. 

In the Design View of a query, in an empty column in the grid below, right click in 
Field, select Zoom, and enter an expression. Eg Commission: ([Amount]*[ 
Commission Rate]) Commission, and click OK. On the Design tab, click Run. The query 
runs, and then displays the calculation based on the expression you entered. 

Here’s a more complex example: Subtotal: ([Quantity]*[Unit Price])-
([Quantity]*[Unit Price]*[Discount]) 

Alternate Approach: You can also right click in the Field area, select Build, and then 
click among the available fields to build an expression, using +_*? Operators between 
the selected fields. Eg type SalesCalc: (then click to add) [Sales]-[Profits]  

You can format the calculated expression by right clicking the column, selecting 
Properties, and then modify the Format profit to show (e.g. Currency) 

Other examples of calculated expressions can be found here. 

https://support.microsoft.com/en-us/office/examples-of-expressions-d3901e11-c04e-4649-b40b-8b6ec5aed41f
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Totals Query  

 

A totals query is a select query that allows you to group and summarize data, like 
when you want to see total sales per product. In a totals query, you can use the Sum 
function (an aggregate function), to see total sales per product. 

Create a new query with the fields you want and open it in Design View. Make sure 
at least one of the fields have numeric values, like Sales amounts. On the Design tab, 
in the Show/Hide group, click Totals. The Totals row is displayed in the query design 
grid.  

Essentially you group by one or more fields, and set a subtotal (sum) for the field that 
has numeric values. Eg for the Employees field, select Group By in the Totals area (to 
indicate that each employee will only be listed once); and for the Sales field, select 
Sum for the Total Field (to create a subtotal of Sales for each employee). 

On the Design tab, in the Results group, click Run. The query runs, and then displays 
a list of products with subtotals. Save the query.  

Crosstab Query  

 

A Crosstab query allows you to see data in a kind of 3D view. I.e. there are headings 
both down and across the top. Eg suppose you want to see salespeople listed on the 
left, and the dates they made sales across the top, and the actual Sales subtotal 
amounts in between.  

Create a new query and then open it in Design view. Eg it can have Employees, Dates, 
and Sales amounts. 

On the Design tab, in the Query Type group, click Crosstab. In the design grid, the 
Show row is hidden, and the Crosstab row is displayed. The Totals row also shows. 

For the Employee field, in the Crosstab field, select Row Headings.  For the Date field, 
in the Crosstab field, select Column Headings.  For the Sales field, in the Totals field, 
select the Sum function, and in crosstab make sure Values is selected. 

On the Design tab, in the Results group, click Run. The crosstab query runs. 

You could as an experiment in the Design View, flip Employees to Row Headings, and 
Dates to Column Headings, and change the Totals function to Average or Count.  

Save the query. 

Parameter Query  

 

With a Parameter Query the User is prompted to enter the values for a criteria when 
the query runs; instead of the criteria being previously defined.   

To create a parameter query, first create a select query. Then open it in Design view. 
In the Criteria row of the field you want to apply a parameter to, enter the text that 
you want to display in the parameter box, enclosed in square brackets. For example, 
in a date-related field enter [Enter the start date]. Repeat for other fields you want 
to add parameters to in the query. 

When you run the query, the prompt appears without the square brackets. E.g. it says 
“Enter the start date.” Fill in the value you want to see the records from the one or 
multiple parameters, and then click OK. 

You can also create a start and end range within a Parameter criteria. For example, 
you could enter in the criteria area of a field Between [Enter the start date:] And 
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[Enter the end date:] in the criteria area, which will generate two prompts within that 
one parameter.   

Action Queries   An Action Query does something to the data set of records showing in the query, 
such as Updating a field within the records by a certain amount, Deleting certain 
records based on a condition, Appending records from one table to another, and 
creating a whole New Table out of certain existing records.  

 

Update Query  

Use an update query to change the data in your tables; eg increase Staff salaries by 
10%. 

-Be sure to backup your database before continuing. 

-Create a new table with four fields, ID as Autonumber, StaffName as Short Text, 
State as Short Text delimited to 2 characters, and Salary as Number formatted as 
Currency. Save the table as Staff. Enter several records, filling in the state with one 
or more instances where the state is CA and NV. Close all objects. 

-Click Create, select Query Design, and add the Staff table. Add the Salary field. Click 
Update button on the Design tab. In the Update To area enter the following: 
[Salary]*1.1. Then click Run, and then Yes to update all the records. To verify this 
works, open the Staff table on the left. 

Note: Normally you close the Query and not save it, unless you want to increase the 
Salaries regularly by 10%.   

 

Delete Query 

You can use a delete query to delete data from your tables. You can enter criteria to 
specify which rows should be deleted, such as all staff members from Nevada. 

-Click Create, select Query Design, and add the Staff table. Add the State field. Click 
Delete button on the Design tab. In the criteria area enter “NV” indicating that we 
want to delete the Nevada records. Then click Run, and then Yes to update all the 
records. To verify this works, open the Staff table on the left. 

Note: Normally you close the Query and not save it, unless you want to delete records 
where the state is Nevada.  

 

Append Query 

Use an append query to retrieve data from one or more tables and add that data to 
another table so it now has even more records. 

-Duplicate the Staff table, but select only the Structure, not the data. Name the table 
StaffHistorical. Click Create, select Query Design, and add the Staff table. Add all the 
fields. Select Append from the Design view. Select the StaffHistorical table to append 
to (in current database). (Optionally you can enter criteria like “CA” but we won’t do 
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that here.) Click Run, then Yes. Then check in the StaffHistorical table for the newly 
appended records. 

Note: Normally you close the Query and not save it, unless you want to append 
additional records from the Staff table to the StaffHistorical table.  

 

Make Table Query   

You can use a Make Table query to take data from the current table and add it to a 
new table. Eg let’s say you want to create a duplicate version of the Transactions 
table that only has data for that customer that you want to forward to them, so they 
can’t see other customer’s data. 

(we’ll create a new database and table to do this) 

-Create a new file – eg called MakeTableExample.  

-Then create a new table with a few fields. ID, Name, and Amount. Name it 
Transactions. Then enter a few records (including a few values over 100 in the 
amount.) 

-Then Create a new query, and add the fields from the table to the query. Save it as 
Amount100Qry. 

-Then set criteria for one of the fields (e.g. Amount >=100).  Run the query. 

-Then open it in Design View. On the Design tab, in the Query Type group, click Make 
Table. In the Make Table dialog box, in the Table Name box enter Amount100, and 
then click OK.   

-On the Design tab, in the Results group, click Run. In the confirmation dialog box, 
click Yes, and see the new table displayed in the Navigation Pane.  

 

Use Find Unmatched 
Query Wizard to 
Compare Two Tables 

 

-On the Create tab, in the Queries group, click Query Wizard.  
-In the New Query dialog box, double-click Find Unmatched Query Wizard. 
-On the first page of the wizard, select the table that has unmatched records, and 
then click Next. For example, if you want to see a list of Northwind products that have 
never been sold, select the Products table. 
-On the second page, select the table that is related, and then click Next. To follow 
the example, select the Order Details table. 
-On the third page, select the fields that relate the tables, click < = >, and then click 
Next. You can choose only one field from each table. To follow the example, select 
ID from the Products table and Product ID from the Order Details table. Verify that 
the correct fields are matched by reviewing the text in the Matching fields box. 
Note that the ID and the Product ID fields may already be selected because of existing 
relationships built into the template. 
-On the fourth page, double-click the fields that you want to see from the first table, 
and then click Next. To follow the example, select the ID and Product Name fields. 
-On the fifth page, you can choose to view the results or to modify the design of your 
query. In this example, click View the results. Accept the suggested name for the 
query, and then click Finish.  
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REPORTS 

Intro There are several ways to create a report.  One is through the Report Wizard. It 
guides you step by step to make choices to create the report, ranging from simple 
reports to the most complex, including grouped and subsorted data. Another is to 
create an empty Blank Report, and then add content and otherwise alter it to meet 
the conditions one wants. Yet a third is to create a Simple Report. 

Create Report Using 
Report Wizard 

Build A Grouped Report  

A report can be a simple listing of rows of data or be a grouped report, such as 
grouping the Transactions records per each Customer. 

On the Create tab, in the Reports group, click Report Wizard.  Access starts the Report 
Wizard. 

-Select Table/Query , Fields 

Click the Tables/Queries drop-down list and choose the table or query that contains 
the fields you want on your report. (e.g. ContactsQry) Queries can include simple 
single-table based ones or ones where multiple tables are joined and others.  

Double-click fields in the Available Fields list to choose them. (Tip: It’s best not to 
choose all of them the first time around, but the key ones. You can later add any of 
the other.) Access moves them to the Selected Fields list. (Alternatively, you can click 
the buttons located between the Available Fields box and the Selected Fields box to 
add or remove the selected field or to add all or remove all of the fields. If there are 
fields in another table or query that you also want to put on your report, click the 
Tables/Queries drop-down list again and choose the other table or query, and 
continue to add fields.) After you've finished adding fields, click Next. 

-Group Records 

Grouping lets you organize and arrange records by group, such as by Region or 
Salesperson. Groups can be nested one within another so that you can easily identify 
the relationships among the groups and find the information you want quickly. You 
can also use grouping to calculate summary information, such as totals and 
percentages. When you include more than one table in a report, the wizard examines 
the relationships between the tables and determines how you might want to view 
the information. Please note that you don’t have to have grouping in your report, 
though its use makes the result more dynamic. 

On the page of the Report Wizard that asks Do you want to add any grouping levels?, 
click one of the field names in the list you want to group on (eg ContactName), and 
then click the right arrow button. 

You can also an additional grouping level(s) (actually sub-grouping) in the same way. 
You can also remove a grouping level by highlighting it on the right and then clicking 
the Back arrow.  You can also adjust the priority of a grouping level by selecting it and 
clicking the up or down priority buttons. Access adds each grouping level and shows 
it nested within its parent grouping level. 

--- 
(optional) Click Grouping Options to display the Grouping Intervals dialog box. Optionally, for 
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each group-level field, choose a grouping interval. The grouping interval lets you customize 
how records are grouped. In the previous illustration, records are grouped on the 
ShippedDate field, which is a Date/Time data type. The Report Wizard offers choices 
appropriate to the field type in the Grouping intervals list. Thus, because ShippedDate is a 
Date/Time type, you can choose to group by actual value (Normal), Year, Quarter, Month, 
Week, Day, Hour and Minute. If the field were a Text data type, you could choose to group 
by the entire field (Normal), or perhaps by the first one to five characters. For a numeric data 
type, you can choose to group by value (Normal), or by range in selected increments. After 
selecting a grouping interval, click OK. 

--- 

Click Next to navigate to the next page of the wizard. 

-Sort Records 

You can sort records by up to four fields, in either ascending or descending order. 

Click the first drop-down list and choose a field on which to sort. You can click the 
button to the right of the list to toggle between ascending and descending order 
(Ascending is the default). Optionally, click the second, third, and fourth drop-down 
lists to choose additional sort fields. 

--- 

Summarize Records 

Click Summary Options if you want to summarize any of the numeric fields, such as the Sum 
of the Amount field for all the records, or the sum of each of the groupings such as the Sum 
of all the Amounts per each Customer grouping. 

Note that the Summary Options button will only be visible if you have one or more numeric 
fields in the Detail section your report. The wizard displays the available numeric fields. 
Select the check box under your choice of Sum, Avg, Min or Max to include those calculations 
in the group footer. You can also choose to show the details and summary or the summary 
only. In the latter case, totals for each ShippedDate value are shown (if you selected the 
check box for Sum, for example), but the order detail is omitted. You can also choose to show 
percent of total calculations for sums. Click OK. 

-Remainder of Wizard 

Follow the directions on the remaining pages of the Report Wizard. Eg you may see 
the various layout options to choose from; the orientation the page should be 
(portrait, landscape); and the title of the report (eg change to eg rptContacts). This 
title will be displayed on the first page of the report, and Access will also save the 
report, using the title as the document name. You can edit both the title and the 
document name later. 

Click Finish. Access automatically saves the report and displays it in Print Preview, 
which shows you the report as it will look when printed. 

-View Report in Preview mode 

You can use the navigation buttons at the bottom of the preview pane to view the 
pages of the report sequentially or jump to any page in the report. Click one of the 
navigation buttons or type the page number that you want to see in the page number 
box, and then press Enter. 
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In Print Preview, you can zoom in to see details or zoom out to see how well data is 
positioned on the page. With the mouse pointer positioned over the report, click 
once. To reverse the effect of the zoom, click again. You can also use the zoom control 
in the status bar in the lower right to return to 100% 

Changing Report 
Controls in Layout 
View 

Once you have built the report, you will likely need to make changes. One main set 
of changes is moving the fields around to the locations you want, changing the width 
or height of the field, eliminating some of the fields, changing or eliminating the 
labels the wizard created, etc. These can all be done in Design View, but a number of 
them can be more easily done in Layout View. 

-To open Layout View, right click the tab for the Report and select Layout view. 

Among the things you can do in Layout view are: 

-At the top of the page triple click the text, and change it. 

-Click any field that has pound signs and then widen it by dragging the left or right 
side of the box that surrounds it. All data for that field is widened. 

-Do the same for the other fields, moving them left or right.  

-Double click each of the labels at the top of the page and change the wording. Also 
move the labels left and right so they correspond to the appropriate field below it. 
You can also click in the middle of a label and move it left or right, or up and down. 

-Click on the grouping field in the upper left (eg Belly Delly), click the Format tab, and 
select a larger size (e.g. 12) and make it bold. 

-If a field has a box around it, click on it, and then activate the Design tab, and click 
Property Sheet on the right. Change the Border Style property from Solid to 
Transparent from the pop-up. 

-Click the statement at the end of the first group of records (“Summary …”), and hit 
the Delete key to delete it. 

-Widen a Sum calculation you might have at the end of the first grouping of records, 
and then make it bold. (You can also do the same by going to the last page and make 
similar changes to the Grand Total calculation at the end of the report. 

-You can get rid of the gray banding in a report by clicking on a range, eg under a 
customer name grouping. and on the Property sheet click the Format tab and change 
the Alternate Back Color property to No Color. You can do the same for the Sum 
calculation that may appear at the end of each grouping of records, as well as the 
grouping field (eg the customer name). 

-Switch to Report view and scroll through the pages to see the results. 

Changing Report 
Controls in Design 
View 

Overview -- Design View had much more capability than Layout View, but is also 
more complex to work with. A combination of Layout and Design View is generally 
the best approach. 

To switch to Design View, right click the tab for the report and select Design View. 

Sections of Design View – Typically after using the Report Wizard a report is created 
which can be seen in different sections in Design view. Normally a Report header is 
the top section, and Report Footer the last section. If you grouped records in the 
wizard, say by Region, you will see a group header and a group footer sections. Then 
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there is the Details section, which normally under the group header. and which shows 
(in this case) shows the sub-records for each grouping (here Regions).  

Here are some of the more basic changes you can make in Design View of a report: 

Delete, Move, Change Shape/Size of Fields and Labels -- For each field the wizard 
creates, there will be the label control as well as the field control itself.  

You can also stretch and contract field controls by clicking on their edge, and then 
pulling them out or down by getting the two-headed arrow on the edge and then 
dragging it. Similarly, you can make them taller. (Please note that it’s easier to make 
these changes in Layout View.) 

Change Properties of Controls with Property Sheet -- You can also change the 
properties of the controls, such as their formatting properties like bold, italic, font 
size, etc., or the size and width. To do this, right click any control, whether label of 
field itself and select properties. You see the Properties sheet with various tabs.  

Among other important property changes to make are: 

-Rid the border around a field, by clicking field, and change the Border Style property 
from Solid to Transparent. 

-Change the Format property of a number from (nothing) to Currency. 

-Select a field that has a defined Text format, click the Data tab in properties, then 
change the text Type from Plain Text to rich text, allowing for bold, italic, etc. among 
the text in the field. 

-Click in the background of an area of the report and change the Alternate Back Color 
property to No Color to eliminate gray banding and similar. 

-View the data source for the report by clicking the little square in the upper left 
corner and then view the Record Source property. 

Add or Modify 
Grouping and Sorting 
Levels in an Existing 
Report 

 

Intro  

If you have an existing report and you want to add sorting or grouping to it, or if you 
want to modify the report's existing sorting or grouping, this section can help you get 
started. 

Use, Display the Group, Sort, and Total pane 

Working in the Group, Sort, and Total pane gives you the most flexibility when you 
want to add or modify groups, sort orders, or totals options on a report.  

To see the Group and Sort pane, open any existing report in Design (or Layout) View.  
(Note: These are instructions for Design view, though they are similar in Layout view). 
The Group and Sort pane normally appears below the main Layout area. If not, on 
the Design tab, in the Grouping & Totals group, click Group & Sort.  

You see any groupings previously created.   

To add a new sorting or grouping level, click Add a group or Add a sort. A new line is 
added to the Group, Sort, and Total pane, and a list of available fields is displayed. 

If you added a Group, such as for grouping of records by Employee Name, you would 
then need to add one or more fields from the Add Existing fields choice on the Tools 



 20 

area of the Design tab. E.g. drag the EmpName field from the Add Existing fields 
listing to the new (Employee Name) grouping area. That way the data for the group 
would show when you Preview it.  

Notes: 

-In the Group, Sort, and Total pane, any Sorts should normally be below (i.e. come 
after) the Grouping level, before it. You can move it up or down by clicking in the Sort 
in the pane, and then way on the level you can click the up or down arrow to promote 
or demote. 

-If there are already several sorting or grouping levels defined, you may need to scroll 
down in the Group, Sort, and Total pane before you can see the Add a group and Add 
a sort buttons. 

You can delete a grouping level, by clicking the X way over to the left of the listed 
grouping level. 

-You can define up to 10 grouping and sorting levels in a report. 

Change the Order of 
Grouping and Sorting 
Levels 

To change the order, priority of a grouping or sorting level, from first to last, click the 
row in the Group, Sort, and Total pane and then click the up arrow or the down arrow 
on the right side of the row. 

Create New Grouped 
Report Based on 
Earlier One 

TIP! - Let’s say you created a report with grouping, but now you want another report 
with the same basic layout, but have a different field to group by. To do this, you can 
simply copy and then paste the Report object, open the new report in Design View, 
and then use the Group and Sort tool to change to a different field to group by. You 
would then also need to move the field from the old grouping down into the Details 
area,  and move the new grouping field up  the Details to the changed Group Header.  

Change Sort and 
Grouping Options 

 

Each sorting or grouping level has a number of options that can be set to obtain the 
results you want. To display all the options for a grouping or sorting level, click More 
on the particular sort or group you have defined and want to change. To hide the 
options, click Less. 

SORTING: You can change the sort order by clicking the sort order drop-down list, 
then clicking the option you want. Eg sort by Date, from Oldest to Newest. 

GROUPING: You can change various grouping settings for any grouping level you 
have. 

--Special Grouping Intervals - This setting determines how the records are grouped 
together.  

One advanced feature is to select By Entire Value and then select By First Character 
to group on the first character of a text field so that all (eg employee names) that 
start with "A" are grouped together, all that start with "B" are grouped together, and 
so on. For a date field, you can group by day, week, month, quarter, or you can enter 
a custom interval.  

--Group Totals    To add totals, click this option. You can add totals on multiple fields, 
and you can do multiple types of totals on the same field. 



 21 

-Click the Total On drop-down arrow and select the field you want to have 
summarized. 

-Click the Type drop-down arrow and select the type of calculation to perform. 

-Select Show Grand Total to add a grand total to the end of the report (in the report 
footer). 

-Select Show group totals as % of Grand Total to add a control to the group footer 
that calculates the percentage of the grand total for each group. 

-Select Show in group header or Show in group footer to display the total in the 
desired location. 

Once all the options have been chosen for a field, you can repeat the process and 
summarize another field by selecting the other field from the Total On drop-down 
list. Otherwise, click outside the Totals pop-up window to close it. 

--Title    This allows you to change the title of the field being summarized. This is used 
for the column heading and for labeling summary fields in headers and footers. To 
add or modify the title: Click the blue text following with title. The Zoom dialog box 
appears. Type the new title in the dialog box, and then click OK. 

--With/without a header section    Use this setting to add or remove the header 
section that precedes each group. When adding a header section, Access moves the 
grouping field to the header for you. When you remove a header section that 
contains controls other than the grouping field, Access asks for confirmation to 
delete the controls. 

--With/without a footer section    Use this setting to add or remove the footer 
section that follows each group. When you remove a footer section that contains 
controls, Access asks for confirmation to delete the controls. 

--Keep group together    This setting determines how groups are laid out on the page 
when the report is printed. You may want to keep groups together as much as 
possible to reduce the amount of page turning that is needed to see the entire group. 
However, this usually increases the amount of paper needed to print the report, 
because most pages will have some blank space at the bottom. 

--Do not keep group together on one page    Use this option if you are not concerned 
about groups being broken up by page breaks. For example, a group of 30 items may 
have 10 items on the bottom of one page and the remaining 20 items at the top of 
the next page. 

--Keep whole group together on one page    This option helps minimize the number 
of page breaks in a group. If a group cannot fit in the remaining space on a page, 
Access leaves that space blank and begins the group on the next page instead. Large 
groups may still span multiple pages, but this option minimizes the number of page 
breaks within the group as much as possible. 

--Keep header and first record together on one page    For groups with group 
headers, this ensures that the group header will not print by itself at the bottom of a 
page. If Access determines that there is not enough room for at least one row of data 
to be printed after the header, the group begins on the following page. 
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Delete Grouping and 
Sorting Levels 

 

To delete a grouping or sorting level, click the row you want to delete in the Group, 
Sort, and Total pane, and then press DELETE or click the Delete button on the right 
side of the row. When you delete a grouping level, if the grouping field was in the 
group header or footer, Access moves it to the report's Detail section. Any other 
controls that were in the group header or group footer are deleted.  

Create a Blank Report  To create a report with no controls or preformatted elements: On the Create tab, in 
the Reports area, click Blank Report. Access opens a blank report in Layout view, and 
displays the Field List pane. 

In the Field List pane, click the plus sign (+) next to the table or tables that contain 
the fields that you want to see on the report. To add a field to the report, drag it onto 
the report. To add several fields at once, hold down CTRL and click several fields, and 
then drag them onto the report at the same time.  

If you want to have grouping with subsorts and other more complex arrangements, 
there is an easier method to make such changes rather than doing it by yourself in 
Design View by moving things around. This method is explained in the section below 
called “Add or Modify Grouping and Sorting in an Existing Report.” 

Create a Basic Report  To create a basic report, click on a table or query on the left, and the  on the Create 
tab, in the Reports area, click Report. You can use Layout view to easily move fields 
and labels around, do sorting and grouping as explained earlier.s 

Export Report as PDF Right click a Report in the list, select Export, and then PDF or XPS, then save file to 
whatever destination you choose in PDF format, which comes up by default. Open 
the PDF file as necessary to view. 

Filtering a Report You can use most of the filter commands that are available for tables and queries and 
forms in a Report. Eg, first click in a column in the Report, and then select the Filter 
button on the Home tab, and then make a choice. 

Parameterize Report If a report is based on a query with a parameter in it, then when the Report runs you 
will be prompted for your input just like the Parameter Query, which will then filter 
the report based on your input. 

Create Calculated 
Expression 

Open a report in Design view. Select Design, Controls, Text Box.  

In the Details section click over to the right, just below the Details band.  

Select Design, Tools, Property Sheet, Select the Data tab, and click in the 
ControlSource box, and select the Expression Builder button (…). In the Expression 
Builder type e.g. [Product Total]*1.1. (or double click e.g. Product Total field from 
middle area). Select OK.  

In the Property sheet select the Format tab, select the right side of the Text Align box 
and then select Right. Select the right side of the Border Style box, and select 
Transparent. Close the Property Sheet. Select Format, Number, $.  

Delete the label. Select Design, Controls, Label. In the Page Header section, click on 
the right side just below the Page Header band, and type eg Proposed Increase. View 
in Report view 
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Create a Control with 
Function In it 

In Design View of report, click on the Text Box object and drag it into the report 
somewhere.  Remove its label. Select the data tab in property sheet. Click Build and 
create the expression: eg =sum([TransactionTotal]) 

FORMS 

Ways to Build a Form There are several ways to create a form. Among them are: 

Create Form from Form Wizard -- On the Create tab, in the Forms group, click Form 
Wizard. Follow the directions on the pages of the Form Wizard. On the last page of 
the wizard, click Finish. You can make design changes like adjusting the size of the 
text boxes to fit the data, if necessary. 

Note: The Form Wizard can create a variety of results depending on the options that 
you select. As a result, we recommend that you run the wizard several times, 
experimenting with different options each time, until you get the results that you 
want. 

Create a form from an existing table or query -- To create a form from a table or 
query in your database, in the Navigation Pane on the left, click the table or query 
that contains the data for your form, and on the Create tab, in the Forms area, click 
Form. Access creates a form and displays it in Layout view. You can make design 
changes like adjusting the size of the text boxes to fit the data, if necessary.  

Note Form/Subform: If the form’s underlying table had a one to many relationship 
with another table, then clicking the Form button will not only produce a form, but 
also a subform under it, with sub records in the lower form changing when you shift 
among the records in the upper (host) form. 

Split Form – A split form shows a form on the top half, and the all the records in 
datasheet view in the lower half. When you go to a record in one, the other is 
correspondingly selected. To create a split  form, select a table or query on the left, 
then select Create/ Forms area and from More Forms select Split Form.   

More info on Split Form: https://support.microsoft.com/en-us/office/create-a-split-
form-e8eb0efb-2fa6-4315-9d4b-86e79a1fbe1e 

Create a blank form in Access -- To create a form with no controls or preformatted 
elements: On the Create tab, click Blank Form. Access opens a blank form in Layout 
view, and displays the Field List pane. 

In the Field List pane, click the plus sign (+) next to the table or tables that contain 
the fields that you want to see on the form. To add a field to the form, drag it onto 
the form. To add several fields at once, hold down CTRL and click several fields, and 
then drag them onto the form at the same time. 

Using Form Controls in 
Design View 

Fields and Label Controls -- For each field you drag into the form or the wizard 
creates, there will be the label control as well as the field control itself. When you 
move the field, the label will move along with it. However, if you click on the little 
box in the upper left corner of the field control, only the field will move, without the 
label. 

Change Shape/Size of Fields and Labels -- You can also stretch and contract fields by 
clicking on their edge, and then pulling them out or down by getting the two-headed 

https://support.microsoft.com/en-us/office/create-a-split-form-e8eb0efb-2fa6-4315-9d4b-86e79a1fbe1e
https://support.microsoft.com/en-us/office/create-a-split-form-e8eb0efb-2fa6-4315-9d4b-86e79a1fbe1e
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arrow on the edge and then dragging it. Note that fields where you expect to enter 
lots of text should be taller so you can see more info without scrolling, which the 
Form wizard usually sets for you. 

Field Order Property -- Once you have the fields in the right o position you want them 
in, you can ensure that you can tab in the right order among the fields in Form View.  
You do this by manipulating the Tab order property of the field control. Click on a 
field in Design View of the form, right click and select Properties, click the Other tab 
at the top of the properties list ion the left, and set the Tab Order number for the 
field. Usually the ID field is zero, and for each additional field you start with 1, and go 
up from there for each field based on the order you want them in. Go into Form View 
to try it out.  

OR: 

The Tab Order dialog (Design/Tools/Tab Order) shows the current order of controls 
in the selected Tab Order. To change the order, select a list item by clicking the grey 
button next to its name. Release the mouse then drag the selected item up or down 
the list to create the desired order. You can select multiple items and move several 
at once if required. 

You can use the Auto Order command to have Access automatically create a tab 
order. If there is more than one column of controls on a form the automatic tab order 
will visit items left-to-right before moving down. 

Entering Data into a 
Form 

To enter data into the form, open it from the list of Forms on the left.  Click in the 
first available field (but not the ID field) and start entering data by typing it in or 
selecting from pop-up, etc. and then hit Tab or enter to move to next field. Continue 
entering this way. Shift Tab goes backwards. After you tab past the end of the record, 
it is automatically saved. 

To change a record, go to it, make the change and then select one of the arrows at 
the bottom of the screen to go to another record, or select Save or Refresh All in the 
Records area of the Home tab.  

To delete a record, click on the narrow long rectangle to the left of the record so it is 
highlighted with dark background, and then click on the Delete arrow (not Delete 
itself) in the Records area of the Home tab, and select Delete Record from the pop-
up. 

Sorting, Filtering, 
Searching Form 

Sorting – To sort the form, click in the desired field to sort by and then click 
Home/Sort and Filtering/Ascending (alphabetical or lowest to highest value) in the or 
Sort Descending (reverse alphabetical or highest to lowest value). When you are done 
sorting, click Remove Sort.  

Filtering – Method 1: To filter the form (i.e. delimit the number of records showing 
by a criteria), click in the desired field to filter by and then click Home/Sort and 
Filtering/ and click the Filter (big funnel) icon. Then from the dialogue box, unselect 
and select the criteria you want, and click OK. Only the records that meet the criteria 
are visible. To unfilter, click the highlighted Filtered button at the bottom of the page.  

Predefined Filters: From the pop-up that appears by clicking the Filter bottom, you 
can also select one of the predesignated filters that appear for Numbers, Date, and 
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other type fields. Eg, for Numbers you can select greater than or equals to and enter 
the amount; for a date field you could select this week or this month or next month, 
etc. You can now move among the records that meet this criterion. 

Method 2 (Advanced): To filter the form, click in the form, on the Home tab, select 
Advanced and then Filter by Form in the Sort and Filter area. Select the criteria from 
one or more of the pop-ups that appear next to the fields, and then select Toggle 
Filter from the Sort and Filter area. Click Toggle Filter again to unfilter. 

Searching -- Method 1: To search for content among the records, click in the Search 
box in the bottom of the screen and type in what you are looking for. E.g. type “Long” 
and you will go to the first instance. If you then hit enter you will go to the next 
instance. Be sure to remove the search criteria at the bottom of the page when you 
are done. Method 2: On the Home tab select Find in the Find area, type in the desired 
value, and click Next. Note to select from Match choices of Whole Field or Any Part 
of Field. You can also follow this basic procedure with Find and Replace. 

Tabular Form You can also create a form (based on table or query data) that looks like a list that 
you can easily filter and sort, as well as use it to sequence to the main form that holds 
more of the details.  

To create the tabular form, use the Form Wizard and be sure to select Tabular as the 
type of form towards the end of the wizard.  

After that you might consider creating a button that appears at the end of each 
record which when clicked on opens the main Form that holds the details of 
information per each record. (explained next) 

Using Control Wizard 
in Forms 

Create Button to Open Query to Add Lookup Data 

If you use a lookup field that looks up the data from a table (or query), you normally 
have to open the other form that is being looked up to add additional entries. To 
make that easier you can simply create a button next to the lookup field you want to 
add data to, and the other table or query (or form) will open so you can add 
additional data.  

To do that, in Design view of a form (such as Sales Entry), click the Design tab, and 
then click the Button (the 4th one from the left) in the Controls area. Then draw the 
button on the form so just to the right of e.g. the Customer Names lookup field. The 
wizard begins. Select Miscellaneous on the left and Run Query on the right, Next, 
select the desired query (that eg has the list of Customers), Next, Finish. You can now 
resize the button when you are done. Then try it out in Form view. 

Create Button to Sequence Two Forms  

You can create a button that when you click on it causes you to open another form 
to the corresponding record of the current form.  

To do that start creating dynamic button as explained above. Then select Form 
Operations on the left, then Open Form on the right and click Next, select which 
destination form the button should open, Next, Open the form and show all the 
records should be selected, Next, select Next to accept the default picture in the 
button, Name the Button (eg SequenceForms), and click Finish. 
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Create Buttons to Save, Delete Record 

You can create a button that saves/updates records and a button to delete a record. 

To do that, in Design view of a form (such as Sales Entry), click the Design tab, and 
then click the Button button (the 4th one from the left) in the Controls area. Then 
draw the button on the form say in the upper right of the screen. Click Record 
Navigation on the left, and either Save record or Delete record on the right, click 
Next, click Text round radio button in upper left, and change text to the right of it and 
enter Save or Delete, and then click Finish. Resize and reposition the button as 
desired. Try it out in Form view. 

 

Enable Users To Find A Record By Selecting A Value From A List 

In Design view of Form, select the Combo Box from the Controls area of the Design 
tab and draw a rectangle. The wizard starts. Be sure to select “Find a record on my 
form based on the value I selected in my combo box”. Then select one or more of the 
desired fields to show, etc. Now in Form view try out combo box. When you select a 
record from combo box it opens the same record in the form. 

SubForms (form with 
details inside a host 
form) 

A subform is a form within a form, such as a listing of records in a form that is related 
to a single host parent form. (It is essentially showing data from two different tables.)  

Manually Add Subform to an Existing Form  

Use this procedure to add one or more subforms to an existing form. For each 
subform, you can choose to have Access create a new form or use an existing form 
as the subform. 

Right-click the existing form in the Navigation Pane, and then click Design View. 

On the Design tab, in the Controls group, click the down-arrow to display the Controls 
gallery, and ensure that Use Control Wizards is selected.  

On the Design tab, in the Controls gallery, click the Subform/Subreport button.  

Click on the form where you want to place the subform. 

Follow the directions in the wizard. 

When done Switch to Form View. Now as you move from e.g. customer to 
customer using the arrows in the lower left corner of the screen, you will see the 
related e.g. transactions entry show below it. You can also add additional e.g. 
transactions at the bottom of the e.g. transactions list for each e.g. customer.  

-- 

Create Form with Subforms Using the Wizard 

You can create a Form with a Subform embedded in it by using the Form Wizard  

On the Create tab, in the Forms group, click Form Wizard. 

On the first page of the wizard, in the Tables/Queries drop-down list, select a table 
or query. For this example, to create an Employees form that displays orders for each 
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employee in a subform, we will select Table: Employees (the "one" side of the one-
to-many relationship). 

Note:  It does not matter which table or query you choose first. 

Double-click the fields that you want to include from this table or query. 

On the same page of the wizard, in the Tables/Queries drop-down list, select another 
table or query from the list. For this example, we will select the Orders table (the 
"many" side of the one-to-many relationship). 

Double-click the fields that you want to include from this table or query. 

When you click Next, assuming that you set up the relationships correctly before you 
started the wizard, the wizard asks How do you want to view your data? - that is, by 
which table or query. Select the table on the "one" side of the one-to-many 
relationship. For this example, to create the Employees form, we will click by 
Employees. The wizard displays a small diagram of a form.  

The box in the lower portion of the form diagram represents the subform. 

Note:  If the wizard does not ask How do you want to view your data? that means 
that Access did not detect a one-to-many relationship between the tables or queries 
that you selected. The wizard will continue, but Access will not add a subform to the 
form. You might want to click Cancel and examine your table relationships before 
you continue. Find links to more information about relationships in the See Also 
section. 

At the bottom of the wizard page, select Form with subform(s), and then click Next. 

On the What layout would you like for your subform? page, click the layout option 
that you want, and then click Next. Both layout styles arrange the subform data in 
rows and columns You can add color, graphics, and other formatting elements to a 
tabular subform, whereas a datasheet is more compact, like the datasheet view of a 
table. 

On the last page of the wizard, type the titles that you want for the forms. Access 
names the forms based on the titles that you type, and labels the subform based on 
the title that you type for the subform. 

Specify whether you want to open the form in Form view, so that you can view or 
enter information, or in Design view, so that you can modify its design, and then click 
Finish. 

Access creates two forms - one for the main form that contains the subform control, 
and one for the subform itself.  

To edit Form/Subform go into Design view of host form, and in lower part of screen 
(eg) delete fields as needed, and change labels for fields. Also go into Layout view to 
adjust the column widths. 

OTHER 

Subdatasheets View Existing Subdatasheet Data 
If two tables have a relationship defined in the relationships window that you can see 
a datasheet embedded in another datasheet. Open tblCustomers or tblProducts, click 
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the “+” to the left of any record, and notice how the Transactions are embedded 
(from tblTransactions) within each customer or product.  

Add Records to Subdatasheet  
You can also add records to either the host table or the embedded table. Eg add a 
record to the embedded transactions for the tblCustomer Dames Are Us. Then close 
all tables, reopen tblTransactions and notice the record there. 

Create Subdata Connection   
You may not see subdata if there isn’t a relationship established between the tables 
in the Relationships window. However, You can embed one datasheet inside another, 
so long as they have a matching field.  

To insert a datasheet into current datasheet (that is open such as tblCustomers), 
select Home, Records, More, Subdatasheet, Subdatasheet. Select the table to be 
embedded (eg tblTransactions), to Access message click Yes, which created a link 
between the two tables of two common fields. (if Access cannot find two linking 
fields, it will not work.) Now you can click the + to the left of the host datasheet to 
see the embedded records for that host record. You can modify existing and create 
new subrecords for any record that is embedded. 

Create a Navigator 
Interface 

Access includes a Navigation Control that makes it easy to switch between the 
various forms and reports in your database. A navigation form is simply a form that 
contains a Navigation Control. Navigation forms are a great addition to any desktop 
database. This article describes how to create and modify a navigation form, and how 
to set formatting and display options. 

To create a navigation form, Open the database to which you want to add a 
navigation form. On the Create tab, in the Forms group, click Navigation, and then 
select the style of navigation form that you want. Access creates the form, adds the 
Navigation Control to it, and displays the form in Layout view. 

Add a form or report to a navigation form 

If the Navigation Pane is not already displayed, press F11 to display it. Ensure that 
the navigation form is open in Layout View by right-clicking it in the Navigation Pane, 
and then clicking Layout View. Drag the form or report from the Navigation Pane to 
the [Add New] button. Access creates the new navigation button and displays the 
form or report in the object pane. 

Edit the label at the top of the navigation form 

When you create a new navigation form, Access adds the label “Navigation Form” to 
the form header by default. To edit this label: Open the form in Layout View by right-
clicking it in the Navigation Pane, and then clicking Layout View. Click the label in the 
form header once to select it, and then again to place the cursor in the label. Edit the 
label to suit your needs, and then press ENTER. 

Edit the form caption 

The form caption is the text that appears on the document tab above the form (or in 
the window title bar if you have set the database to display objects as overlapping 
windows). To edit the form caption: 
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Open the form in Layout View by right-clicking it in the Navigation Pane, and then 
clicking Layout View. Right click on the form header near the top of the form, and 
then click Form Properties. In the Property Sheet task pane, on the All tab, edit the 
Caption property to suit your needs. 

Apply an Office Theme to a database 

Office Themes provide a quick way to change all of the colors and fonts that are used 
in a database. These themes apply to all objects in the database, not just the one you 
currently have open. 

Open any form or report in Layout View by right-clicking it in the Navigation Pane, 
and then clicking Layout View. On the Design tab, use the options in the Themes 
group to apply different color and font themes to the database. To only change colors 
without affecting fonts, choose an item from the Colors gallery. To only change fonts 
without affecting colors, choose an item from the Fonts gallery. To change both 
colors and fonts, choose an item from the Themes gallery. In this gallery, you can 
hover over each item to see a live preview of the theme, and then click one to apply 
it. 

Change the color or shape of a navigation button 

Quick Styles enable you to quickly change the color or shape of navigation buttons. 
You can apply unique styles to each button, or apply the same style to all of the 
buttons. 

Open the navigation form in Layout view by right-clicking it in the Navigation Pane, 
and then clicking Layout View. Select the navigation button or buttons that you want 
to change. Use the commands in the Control Formatting group to apply the styles 
you want. 

Set the navigation form as the default display form 

Because a navigation form is often used as a switchboard or “home page” for a 
database, it makes sense to display it by default each time that the database is 
opened. Also, because the Access Navigation Pane is not available in a browser, 
specifying a default Web Display Form is a very important step in creating a Web 
database. 

Use this procedure to set the navigation form as the default display form. On the File 
tab, under Help, click Options. Click Current Database. To set the default form that is 
displayed when you open the database in Access, under Application Options, select 
the form from the Display Form list. To set the default form that is displayed when 
you open the database on a SharePoint server, under Application Options, select the 
form from the Web Display Form list. 

Traditional  
Switchboard Interface 

You can create your own custom interface by following either of these two 
procedure: 

Blank Form Approach 

-From Create menu, select Blank Form in the Forms area. Then in Design view of the 
form, drag a Label control to the header of the page, and type in the title eg Main 
Menu). Then add buttons that open up various forms, reports, etc. by dragging the 
Button control - 4th one from the left in the Controls area -from the Design pane -- 
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into the form, and following the wizard. Eg the button can open a specific Form. 
(Form Operations, Open Form, etc.) 

-Create one button for each object you want to open in the switchboard. 

-You can also add an image for the form, such as the company logo into the header 
(select Logo in the Header / Footer area), or just an image into the body of the form 
(select Insert Image in the Controls area), both from the Design tab. 

-Save the form (eg call it Switchboard). 

-To have the switchboard open automatically when the Access file starts up, select 
File, Options, Current Database, and next to Display Form select the Switchboard 
form, and OK. When you exit Access and reopen the file, the Switchboard form will 
launch automatically. 

 

Tabbed Control on Form Approach 

From Create menu, select Blank Form in the Forms area. Then in Design view of the 
form, drag a Tab control (the 5th one) into the page. Widen the control as needed. 
You can change the Caption property by selecting the tab name, and then right click 
and selecting Properties and adjusting the property in the Property Sheet. Now you 
can drag one of more Button controls to either of the tabs to begin the Button wizard 
to select a possibility (such as opening another form, and going to a New Record. Etc.  
Save the form (eg call it Switchboard). You can also make it the startup screen as in 
previous method. 

Import Data from Excel 
by Copy/Pasting 
(Simple Method) 

With Copy/paste approach you will need to make sure that the data in Excel is laid 
out precisely like the Access table you will be copying/pasting into. (Note: If you have 
an ID field in the Access database table, then it’s best not to have similar data in the 
Excel table.) 

Highlight the data from among one columns in Excel (without the headings), then 
right click and select Copy. Open Access in table or query view and select the first 
empty cell of the first column, hold down the shift key, and click the first empty cell 
of the second column, then right click and select Paste. 

Note that this method works best when the source columns in Excel and in Access 
are next to each other. Thus, it is often best to create a query with the several fields 
that match up with the Excel data. Eg in Excel have the Salesperson, Date, and 
Amount fields be next to each other when you copy them, and likewise have a query 
set up with the corresponding same fields in Access which you will paste into. Then 
follow the copy/paste method above. 

Import Data from Excel 
through Wizard 

To import an Excel spreadsheet into a new table in Access: 

-Open the Access database. 

-If you receive a security warning, click the Enable Content button. 

-On the Office ribbon, select the External Data tab and click Excel.  
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-The "Get External Data - Excel Spreadsheet" wizard appears. In the File name field, 
browse to the Excel file. Select the "Import the source data into a new table in the 
current database" option and click OK. 

-Select the worksheet to import. Click Next. 

-If the first row contains headers, mark the "First Row Contains Column Headings" 
checkbox. Click Next. 

-Select the options for each column or just leave it at the default and click Next. 

-Accept the default of "Let Access add primary key." Click Next. 

-The Import to Table field defaults to the worksheet name. Update it if needed. 
Click Finish. The worksheet imports into a table. 

To import an Excel spreadsheet into an existing table in Access: 

-Ensure that the spreadsheet uses the exact headers as the existing Access 
database. 

-Open the Access database. 

-If you receive a security warning, click the Enable Content button. 

-On the Office ribbon, select the External Data tab and click Excel. 

-The "Get External Data - Excel Spreadsheet" wizard appears. In the File name field, 
browse to the Excel file. Select the "Append a copy of records to the table" option. 
In the drop-down, select the appropriate table and click OK. 

-Select the worksheet to import. Click Next. 

-Click Finish. 

Using Mail Merge 
Wizard 

https://www.youtube.com/watch?v=HlgHWyQ6kho 
 

Normalize data with 
Table Analyzer 

The goal is to create multiple tables from one table, relate them, which helps create 
powerful queries from among them, while dramatically reducing the among of data 
entered. This process is called Normalization. It often occurs after importing a table 
of data from an externa source, such as Excel. 

Running the Table Analyzer Wizard: Open your database and select the table you’d 
like to evaluate from the Navigation pane. 

Click the Database Tools tab. 

Click the Analyze Table button from the Analyze group. 

The Table Analyzer Wizard dialog box appears. 

Read the first two screens if you want (they’re strictly educational); click Next after 
each one. 

Another Table Analyzer Wizard screen appears. Select a table to analyze. 

The name of the table you selected in the Navigation pane should be selected in the 
Tables list. If it is not, click the name of the table you’d like to convert. 

https://www.youtube.com/watch?v=HlgHWyQ6kho
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Click Next. 

In the dialog box that appears, the wizard asks whether you want to just let the wizard 
do its thing (the wizard will decide how the flat-file table should be arranged into 
multiple tables) or if you want to decide which fields go to what tables. 

Click the Yes option (if it’s not already selected) to give the wizard full power in 
deciding the fate of your table, and then click Next. 

If the wizard recommends that you not split your table, click the Cancel button and pat 
yourself on the back for a job well done. This message means that the wizard thinks 
your table is fine just as it is. 

If the wizard does split your table, it will analyze your table and show you its findings. 

The Table Analyzer makes its decision. 

Make sure the information from your flat-file table is grouped correctly into new 
tables: 

If the information is grouped correctly, name the tables by double-clicking each table’s title 
bar and typing a new name in the resulting dialog box. 

If the information is not grouped correctly, use your mouse to drag and drop fields from 
table to table — and then double-click each table’s title bar to rename the tables. 

If you want to create a new table, drag a field into any open space between or around 
the existing tables. The wizard will create a new table window containing the field. 
Double-click the new table’s title bar to rename the table. 

When you’re finished arranging and naming your tables, click Next. 

The wizard automatically selects a key field for each table that it thinks needs a key 
field. Should the wizard select a field incorrectly as a key field, you can correct the 
error. 

If the wizard doesn’t designate a key field properly, you can 

Designate an existing field as a key field by selecting the field and clicking the Set 
Unique Identifier button (looks like a key). 

Change a key-field designation by selecting the proper key field and then clicking the 
Set Unique Identifier button (looks like a key). 

Add a key field by clicking the Add Generated Key button (contains a plus sign and key). 

Click Next for the final step in the process. 

The wizard offers to create a query that looks and acts like your original table. If you 
have reports and forms that work with the flat file, they’ll work with the new query. 

At this point in the process, you may not see the last screen of the wizard as described 
in Step 12; the wizard may tell you that some of your data might be incorrect and that 
you should correct it. For example, if you have a Country field in your table and there 
are two entries such as USA and UAS, the wizard will ask you for — or suggest — a 
correction for the error. You definitely should correct this type of error. 

Unfortunately, the wizard is often not very good at identifying such errors. (It might 
suggest that you change Belgium to Brazil, for example.) Take a quick peek at the data 
for actual errors and move on — because the suggested “corrections” are often 
incorrect! 
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Choose Yes to have the wizard create the query or No to skip query creation. 

Choosing Yes creates a query that runs against the new tables. The query looks and acts 
like the original table. The original table is renamed with an _OLD slapped on the end, 
and any reports and forms use the query (rather than the original table) automatically. 
Choosing No generates the new tables but leaves the original table with its original 
name. 

Click Finish to exit the wizard. 

The wizard completes the process of splitting the flat-file table into a set of relational 
tables. 

SEE VIDEO: 

https://binged.it/2MeQcDz 

Working with 
Graphics, Images, 
Pictures 

-To add an image into the header of the footer of a form, open the form in Design 
view, and on the Design tab in the Header / Footer area, select Logo. Then select the 
desired file. 

-To insert an image anywhere on a form, open the form in Design view, and on the 
Design tab in the Controls area, select Insert Image. Then select the desired image 
file, and draw it anywhere on the form.  

Working with Charts Charts in a Report -- You can e.g. add a chart to the header of a grouped report so 
that you see a chart for each set of records in a grouping, by opening the report in 
Design view, inserting a Chart object in the header, and following the wizard to select 
a table, the desired fields to make up the chart, as well as the common matching 
field.  

Charts in a Form -- You can add a chart of data by going into the Design view of a 
form and then in the Controls area selecting Insert Chart, and selecting the desired 
chart type (e.g. columnar), and draw the chart. Then on the right select the Data 
Source (table, query, etc.), and then choose the desired axis, legend, and values 
fields. 

Conditional Formatting  -In the Navigation Pane, right-click the Table or Query or Report or Listing Form that 
you want to change, and then click Layout View. Select the column or field to which 
you want to apply conditional formatting. 

-On the Format tab, click Conditional Formatting. 

-In the Conditional Formatting Rules Manager dialog box, click New Rule. 

-Click Compare to Other Records 

-Under Edit the rule description, select the options you want, and then click OK. 

TIPS Database Backup -- Back up your database file after every session, including a name 
with date information. Eg select File Save As, and then Save As again, select an 
appropriate location and enter something like Sales 61516 523pm. Then Save, but 
then close the backup file, and resume with the regular file (i.e. called Sales). That 
way if you mess up the current file (e.g. Sales), you can always go back to the backup. 

Note: There also may be times, when you will first need to quit Access and open up 
the regular file again, before doing the backup. 

https://binged.it/2MeQcDz
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There are other ways to backup, but this way is the simplest. (Yu should also have a 
system that backups your data, eg to the cloud with Carbonite, MOZY, or similar.) 

Error Messages with “Parameter” In It – Periodically you may get an error message 
such as one with the word Parameter in it, which will prevent the object from 
working. Sometimes the field in the query no longer works because it has been 
modified, deleted, etc. One strategy is to remove the field in the query and replace 
it with a correct one, or none at all depending on the situation. 

Validation Rules To create a Validation Rule, open your table in MS Access and go to Design View. 
Select the field that you want to add that Validation Rule to. Scroll down and you 
will see the properties pane for that specific field. On the Validation Rule section 
type in the validation rule expression that forces users to type in specific text. Save 
the changes. 

Here are some Validation Rule examples:  

▪ >=0 – accepts zero or higher number 

▪ Between 0 and 1000 – accepts data only within this range 

▪ <#01/01/2007# - accepts date before 2007 only 

▪ Is Null OR >= 0 — accept positive numbers only. 

▪ Search for other validation rules on Google or similar 

You can also enter in the Validation Text area an error message that would appear 
if the user enters data not accepted by the Validation Rule. 

Use these alternatives instead of or in combination with validation rules: 

Required: Setting a field's Required property to Yes forces the user to enter 
something. (In addition to the obvious cases, always consider setting this to Yes for 
your foreign key fields. See #3 in this article for details.) 

Allow Zero Length: Setting this property to No for text, memo, and hyperlink fields 
prevents a zero-length string being entered. 

Additional examples:  

https://support.office.com/en-us/article/restrict-data-input-by-using-validation-rules-b91c6b15-
bcd3-42c1-90bf-e3a0272e988d 

Macros Create A Standalone Macro 
This procedure creates a standalone macro object that will appear under Macros in 
the Navigation Pane. Standalone macros are useful when you want to reuse the 
macro in many places of the application. By calling the macro from other macros, 
you can avoid duplicating the same code in multiple places. 
 

• On the Create tab, in the Macros & Code group, click Macro. 
Access opens the Macro Builder. 

• On the Quick Access Toolbar, click Save. 

• In the Save As dialog box, type a name for the macro, and then click OK. 
 
Continue with the section Add actions to a macro. 
 

http://allenbrowne.com/casu-12.html
https://support.office.com/en-us/article/restrict-data-input-by-using-validation-rules-b91c6b15-bcd3-42c1-90bf-e3a0272e988d
https://support.office.com/en-us/article/restrict-data-input-by-using-validation-rules-b91c6b15-bcd3-42c1-90bf-e3a0272e988d
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Add Actions to a Macro 
Actions are the individual commands that make up a macro, and each is named 
according to what it does, for example, FindRecord or CloseDatabase. 
 
Step 1: Browse or search for a macro action 
The first step in adding an action is finding it in the Add New Action drop-down list 
or in the Action Catalog. 
 
Step 2: Add an action to a macro 
Once you have found the macro action you want, add it to the macro by using one 
of these methods: 

• Select an action in the Add New Action list, or just begin typing the action 
name in the box. Access adds the action at the point where the Add New 
Action list was displayed. 

• Drag the action from the Action Catalog to the macro pane. An insertion bar 
appears to show you where the action will be inserted when you release the 
mouse button. 

• Double-click the action in the Action Catalog. 
 
If an action is selected in the macro pane, Access adds the new action just below 
the selected one. 
If a Group, If, Else If, Else, or Submacro block is selected in the macro pane, Access 
adds the new action to that block. 
If no action or block is selected in the macro pane, Access adds the new action to 
the end of the macro. 
 
Step 3: Fill in arguments 
Most macro actions require at least one argument. You can view a description of 
each argument by selecting the action and then moving the pointer over the 
arguments. For many arguments, you can select a value from a drop-down list. If 
the argument requires you to type in an expression, IntelliSense helps you enter the 
expression by suggesting possible values as you type, as shown in the following 
illustration: 
 

 
 
When you see a value that you want to use, add it to your expression by double-
clicking it or using the arrow keys to highlight it and then pressing the TAB or ENTER 
key. 
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______________ 
 
Create An Embedded Macro 

This procedure creates a macro that is embedded in an event property of an object. 
Such a macro does not appear in the Navigation Pane, but can be called from 
events such as On Load or On Click. 

Because the macro becomes part of the form or report object, embedded macros 
are recommended for automating tasks that are specific to a particular form or 
report. 

• In the Navigation Pane, right-click the form or report that will contain the 
macro, and then click Layout View. 

• If the property sheet is not already displayed, press F4 to display it. 

• Click the control or section that contains the event property in which you 
want to embed the macro. You can also select the control or section (or the 
entire form or report) by using the drop-down list under Selection Type at 
the top of the property sheet. 

• In the Property Sheet task pane, click the Event tab. 

• Click in the property box for the event you want to trigger the macro. For 
example, for a command button, if you want the macro to run when the 
button is clicked, click in the On Click property box. 

• If the property box contains the words [Embedded Macro], this means a 
macro has already been created for this event. You can edit the macro by 
continuing with the remaining steps in this procedure. 

• If the property box contains the words [Event Procedure], this means that a 
Visual Basic for Applications (VBA) procedure has already been created for 
this event. Before you can embed a macro in the event, you will need to 
remove the procedure. You can do this by deleting the words [Event 
Procedure], but you should first examine the event procedure to make sure 
that removing it will not break needed functionality in the database. In some 
cases, you can recreate the functionality of the VBA procedure by using an 
embedded macro. 

• Click the Build button  . 

• If the Choose Builder dialog box appears, make sure Macro Builder is 
selected, and then click OK. 
 
Access opens the Macro Builder. Continue with the next section to add 
actions to the macro. 

 
More help: 
https://support.microsoft.com/en-us/office/create-a-user-interface-ui-macro-
12590d3b-b326-4207-bfe5-19234f53f08b 
 

https://support.microsoft.com/en-us/office/create-a-user-interface-ui-macro-12590d3b-b326-4207-bfe5-19234f53f08b
https://support.microsoft.com/en-us/office/create-a-user-interface-ui-macro-12590d3b-b326-4207-bfe5-19234f53f08b
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Use Excel to Pivot 
Access Data 

 

In Access, click the Data tab, then in the Get and Transform area, click Get Data > 
From Database > From Microsoft Access Database. In the Import Data dialog box, 
browse for file to import (file with your first name), and then click Import. In 
Navigator dialogue box select a multi-table query (eg qryTransactionDetails).  Then 
click Load. A table is created in Excel. Click inside it and select Insert Pivot Table, OK, 
and then build the Pivot Table as normal. Save the file in Excel. 

 


